const regex = new RegExp('(?:catch\\s*\\([^)]+\\)\\s*\\{(?=[^\\}]*\\blog\\.debug\\b)|\\G)\\K([^\\}]*?)(?:\\blog\\.debug\\b[^\\}]*?)', 'g')
const str = `catch (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}
function (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}`;
const subst = `$1log.error`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);