import re
regex = re.compile(r"(?:catch\s*\([^)]+\)\s*\{(?=[^\}]*\blog\.debug\b)|\G)\K([^\}]*?)(?:\blog\.debug\b[^\}]*?)")
test_str = ("catch (Exception e) \n"
"{\n"
" log.debug(\"word\");\n"
" //stuff\n"
" log.debug(\"word2\");\n"
"}\n\n"
"function (Exception e) \n"
"{\n"
" log.debug(\"word\");\n"
" //stuff\n"
" log.debug(\"word2\");\n"
"}")
subst = "$1log.error"
result = regex.sub(subst, test_str)
if result:
print(result)