#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:catch\s*\([^)]+\)\s*\{(?=[^\}]*\blog\.debug\b)|\G)\K([^\}]*?)(?:\blog\.debug\b[^\}]*?)"
Local $sString = "catch (Exception e) " & @CRLF & _
"{" & @CRLF & _
" log.debug("word");" & @CRLF & _
" //stuff" & @CRLF & _
" log.debug("word2");" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"function (Exception e) " & @CRLF & _
"{" & @CRLF & _
" log.debug("word");" & @CRLF & _
" //stuff" & @CRLF & _
" log.debug("word2");" & @CRLF & _
"}"
Local $sSubst = "$1log.error"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)