use strict;
my $str = 'catch (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}
function (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}';
my $regex = qr~(?:catch\s*\([^)]+\)\s*\{(?=[^\}]*\blog\.debug\b)|\G)\K([^\}]*?)(?:\blog\.debug\b[^\}]*?)~p;
my $subst = '$1log.error';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";