# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[^|]*\|){3}([^|]*)/\n/;t' <<< "FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||"