use strict;
my $str = 'FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||';
my $regex = qr/^(?:[^|]*\|){3}([^|]*)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";