import re
regex = re.compile(r"^(?:[^|]*\|){3}([^|]*)")
test_str = "FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||"
subst = "\\n"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)