using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^|]*\|){3}([^|]*)";
string substitution = @"\n";
string input = @"FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}