import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^|]*\\|){3}([^|]*)";
final String string = "FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}