// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:[^|]*\|){3}([^|]*)").unwrap();
let string = "FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}