$re = '/^(?:[^|]*\|){3}([^|]*)/';
$str = 'FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||';
$subst = "\n";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;