package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^|]*\|){3}([^|]*)`)
var str = []byte(`FIM_INVOICES|2017/7|TotalPurchasePrice|SUS.CodaId|401382|PackingListNumber|H0013429|ProductGroup|Baby Apparel||`)
var substitution = []byte("\n")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}