#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<br><br>(?!<br)"
Local $sString = "Test1 is here<br><br>Now comes Test2<br><br>Then test 3<br><br><br>Thats it."
Local $sSubst = "<br>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)