re = /<br><br>(?!<br)/
str = 'Test1 is here<br><br>Now comes Test2<br><br>Then test 3<br><br><br>Thats it.'
subst = '<br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result