import re
regex = re.compile(r"<br><br>(?!<br)")
test_str = "Test1 is here<br><br>Now comes Test2<br><br>Then test 3<br><br><br>Thats it."
subst = "<br>"
result = regex.sub(subst, test_str)
if result:
print(result)