$re = '/<br><br>(?!<br)/';
$str = 'Test1 is here<br><br>Now comes Test2<br><br>Then test 3<br><br><br>Thats it.';
$subst = "<br>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;