use strict;
my $str = 'Test1 is here<br><br>Now comes Test2<br><br>Then test 3<br><br><br>Thats it.';
my $regex = qr/<br><br>(?!<br)/p;
my $subst = '<br>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";