using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^\]]*u:([^\]]*)\]";
string substitution = @"<a href='/user/\1'>\1</a>";
string input = @"Here is a link [u:person]!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}