re = /\[[^\]]*u:([^\]]*)\]/m
str = 'Here is a link [u:person]!'
subst = '<a href=\'/user/\\1\'>\\1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result