import re
regex = re.compile(r"\[[^\]]*u:([^\]]*)\]", flags=re.MULTILINE)
test_str = "Here is a link [u:person]!"
subst = "<a href='/user/\\1'>\\1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)