const regex = new RegExp('\\[[^\\]]*u:([^\\]]*)\\]', 'gm')
const str = `Here is a link [u:person]!`;
const subst = `<a href='/user/\1'>\1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);