#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<folderorurl>(?<folder>(\\[^\\\s",<>|]+)+)|(?<url>https?:\/\/[^\s]+))"
Local $sString = "\server\share" & @CRLF & _
"\folder\subfolder\subsubfolder" & @CRLF & _
"http://www.test.de" & @CRLF & _
"https://example.com" & @CRLF & _
"this is another string that does not get matched" & @CRLF & _
"what about this line?" & @CRLF & _
"and here we have some special characters <> \\<>dsass\<<<>sdadada#++pü+" & @CRLF & _
"is it matching this \folder\subfolder thingy?" & @CRLF & _
"oh, yes, but what about another strange http://www.url.com ?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")