use strict;
my $str = '\\server\\share
\\folder\\subfolder\\subsubfolder
http://www.test.de
https://example.com
this is another string that does not get matched
what about this line?
and here we have some special characters <> \\\\<>dsass\\<<<>sdadada#++pü+
is it matching this \\folder\\subfolder thingy?
oh, yes, but what about another strange http://www.url.com ?';
my $regex = qr/(?<folderorurl>(?<folder>(\\[^\\\s",<>|]+)+)|(?<url>https?:\/\/[^\s]+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}