package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<folderorurl>(?<folder>(\\[^\\\s",<>|]+)+)|(?<url>https?:\/\/[^\s]+))`)
var str = `\server\share
\folder\subfolder\subsubfolder
http://www.test.de
https://example.com
this is another string that does not get matched
what about this line?
and here we have some special characters <> \\<>dsass\<<<>sdadada#++pü+
is it matching this \folder\subfolder thingy?
oh, yes, but what about another strange http://www.url.com ?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}