// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?<folderorurl>(?<folder>(\\[^\\\s",<>|]+)+)|(?<url>https?:\/\/[^\s]+))"#).unwrap();
let string = "\\server\\share
\\folder\\subfolder\\subsubfolder
http://www.test.de
https://example.com
this is another string that does not get matched
what about this line?
and here we have some special characters <> \\\\<>dsass\\<<<>sdadada#++pü+
is it matching this \\folder\\subfolder thingy?
oh, yes, but what about another strange http://www.url.com ?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}