const regex = /(?<folderorurl>(?<folder>(\\[^\\\s",<>|]+)+)|(?<url>https?:\/\/[^\s]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<folderorurl>(?<folder>(\\\\[^\\\\\\s",<>|]+)+)|(?<url>https?:\\\/\\\/[^\\s]+))', 'g')
const str = `\\server\\share
\\folder\\subfolder\\subsubfolder
http://www.test.de
https://example.com
this is another string that does not get matched
what about this line?
and here we have some special characters <> \\\\<>dsass\\<<<>sdadada#++pü+
is it matching this \\folder\\subfolder thingy?
oh, yes, but what about another strange http://www.url.com ?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}