import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<folderorurl>(?<folder>(\\\\[^\\\\\\s\",<>|]+)+)|(?<url>https?:\\/\\/[^\\s]+))";
final String string = "\\server\\share\n"
+ "\\folder\\subfolder\\subsubfolder\n"
+ "http://www.test.de\n"
+ "https://example.com\n"
+ "this is another string that does not get matched\n"
+ "what about this line?\n"
+ "and here we have some special characters <> \\\\<>dsass\\<<<>sdadada#++pü+\n"
+ "is it matching this \\folder\\subfolder thingy?\n"
+ "oh, yes, but what about another strange http://www.url.com ?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}