# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<folderorurl>(?<folder>(\\[^\\\s\",<>|]+)+)|(?<url>https?:\/\/[^\s]+))"
test_str = ("\\server\\share\n"
"\\folder\\subfolder\\subsubfolder\n"
"http://www.test.de\n"
"https://example.com\n"
"this is another string that does not get matched\n"
"what about this line?\n"
"and here we have some special characters <> \\\\<>dsass\\<<<>sdadada#++pü+\n"
"is it matching this \\folder\\subfolder thingy?\n"
"oh, yes, but what about another strange http://www.url.com ?")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.