# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'(?=[^`]*(?:`[^`]*`[^`]*)*$)/’/g;t' <<< "match this one '
```
don't match this
```
match this as well '
```
not this one '
```
yes to this one '
`not this ' one`"