#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "'(?=[^`]*(?:`[^`]*`[^`]*)*$)"
Local $sString = "match this one '" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"don't match this" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"match this as well '" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"not this one '" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"yes to this one '" & @CRLF & _
"" & @CRLF & _
"`not this ' one`"
Local $sSubst = "’"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)