$re = '/\'(?=[^`]*(?:`[^`]*`[^`]*)*$)/';
$str = 'match this one \'
```
don\'t match this
```
match this as well \'
```
not this one \'
```
yes to this one \'
`not this \' one`';
$subst = "’";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;