import Foundation
let pattern = #"'(?=[^`]*(?:`[^`]*`[^`]*)*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
match this one '
```
don't match this
```
match this as well '
```
not this one '
```
yes to this one '
`not this ' one`
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"’"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)