re = /'(?=[^`]*(?:`[^`]*`[^`]*)*$)/
str = 'match this one \'
```
don\'t match this
```
match this as well \'
```
not this one \'
```
yes to this one \'
`not this \' one`'
subst = '’'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result