import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'(?=[^`]*(?:`[^`]*`[^`]*)*$)";
final String string = "match this one '\n\n"
+ "```\n"
+ "don't match this\n"
+ "```\n\n"
+ "match this as well '\n\n"
+ "```\n"
+ "not this one '\n"
+ "```\n\n"
+ "yes to this one '\n\n"
+ "`not this ' one`";
final String subst = "’";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}