use strict;
my $str = 'match this one \'
```
don\'t match this
```
match this as well \'
```
not this one \'
```
yes to this one \'
`not this \' one`';
my $regex = qr/'(?=[^`]*(?:`[^`]*`[^`]*)*$)/p;
my $subst = '’';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";