using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(?=[^`]*(?:`[^`]*`[^`]*)*$)";
string substitution = @"’";
string input = @"match this one '
```
don't match this
```
match this as well '
```
not this one '
```
yes to this one '
`not this ' one`";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}