import re
regex = re.compile(r"'(?=[^`]*(?:`[^`]*`[^`]*)*$)")
test_str = ("match this one '\n\n"
"```\n"
"don't match this\n"
"```\n\n"
"match this as well '\n\n"
"```\n"
"not this one '\n"
"```\n\n"
"yes to this one '\n\n"
"`not this ' one`")
subst = "’"
result = regex.sub(subst, test_str)
if result:
print(result)