const regex = /[^\S\r\n](?=[0-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\S\\r\\n](?=[0-9])', 'g')
const str = `10 000,00 EUR
1 000 000,00 EUR`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);