import re
regex = re.compile(r"[^\S\r\n](?=[0-9])")
test_str = ("10 000,00 EUR\n"
"1 000 000,00 EUR")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)