use strict;
my $str = '10 000,00 EUR
1 000 000,00 EUR';
my $regex = qr/[^\S\r\n](?=[0-9])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";