$re = '/[^\S\r\n](?=[0-9])/';
$str = '10 000,00 EUR
1 000 000,00 EUR';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;