# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\textbf\{([^}]*)\}/$1/g;t' <<< "This little piggy went to market, \textbf{smith1774}
This little \textbf{ben1864} piggy stayed \textbf{mueller2867} home,
This little piggy had roast beef"