$re = '/\\\\textbf\{([^}]*)\}/';
$str = 'This little piggy went to market, \\textbf{smith1774}
This little \\textbf{ben1864} piggy stayed \\textbf{mueller2867} home,
This little piggy had roast beef';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;