using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\textbf\{([^}]*)\}";
string substitution = @"$1";
string input = @"This little piggy went to market, \textbf{smith1774}
This little \textbf{ben1864} piggy stayed \textbf{mueller2867} home,
This little piggy had roast beef";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}