import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\textbf\\{([^\\}]*)\\}";
final String string = "This little piggy went to market, \\textbf{smith1774}\n"
+ "This little \\textbf{ben1864} piggy stayed \\textbf{mueller2867} home,\n"
+ "This little piggy had roast beef";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}