use strict;
my $str = 'This little piggy went to market, \\textbf{smith1774}
This little \\textbf{ben1864} piggy stayed \\textbf{mueller2867} home,
This little piggy had roast beef';
my $regex = qr/\\textbf\{([^}]*)\}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";