#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\\textbf\{([^}]*)\}"
Local $sString = "This little piggy went to market, \textbf{smith1774}" & @CRLF & _
"This little \textbf{ben1864} piggy stayed \textbf{mueller2867} home," & @CRLF & _
"This little piggy had roast beef"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)