const regex = /\\textbf\{([^}]*)\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\textbf\\{([^}]*)\\}', 'g')
const str = `This little piggy went to market, \\textbf{smith1774}
This little \\textbf{ben1864} piggy stayed \\textbf{mueller2867} home,
This little piggy had roast beef`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);