// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\textbf\{([^}]*)\}").unwrap();
let string = "This little piggy went to market, \\textbf{smith1774}
This little \\textbf{ben1864} piggy stayed \\textbf{mueller2867} home,
This little piggy had roast beef";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}