import re
regex = re.compile(r"\\textbf\{([^}]*)\}")
test_str = ("This little piggy went to market, \\textbf{smith1774}\n"
"This little \\textbf{ben1864} piggy stayed \\textbf{mueller2867} home,\n"
"This little piggy had roast beef")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)